rustsec

Crates.iorustsec
lib.rsrustsec
version0.29.3
sourcesrc
created_at2017-02-26 02:31:58.979516
updated_at2024-05-24 17:58:46.019754
descriptionClient library for the RustSec security advisory database
homepagehttps://rustsec.org
repositoryhttps://github.com/RustSec/rustsec/tree/main/rustsec
max_upload_size
id8687
size236,520
Sergey "Shnatsel" Davidoff (Shnatsel)

documentation

README

RustSec: rustsec crate

Latest Version Docs Build Status Safety Dance MSRV Apache 2.0 OR MIT licensed Project Chat

Client library for accessing the RustSec Security Advisory Database: fetches the advisory-db (or other compatible) git repository and audits Cargo.lock files against it.

Documentation

About

The rustsec crate is primarily intended to be used by the cargo-audit crate for the purposes of identifying vulnerable crates in Cargo.lock files.

However, it may be useful if you would like to consume the RustSec advisory database in other capacities.

Minimum Supported Rust Version

Rust 1.70 or higher.

Minimum supported Rust version can be changed in the future, but it will be done with a minor version bump.

License

Licensed under either of:

at your option.

Contribution

Unless you explicitly state otherwise, any contribution intentionally submitted for inclusion in the work by you shall be dual licensed as above, without any additional terms or conditions.

Commit count: 2283

cargo fmt